msvrtan's blog

Upgrading from Symfony 2.2 to 2.3

After upgrading from Symfony 2.2 to 2.3, when I would try to purge production cache with

php app/console cache:clear --env=prod --no-debug

I got error saying:


The parameter "kernel.http_method_override" must be defined.

For some strange reason this error happens only in production mode, I found out that deleting "app/cache/prod" folder and all of its contents solves it.

P.S. This was only problem I had with upgrading from 2.2 to 2.3 so upgrade went pretty smoothly..